均线粘合公式

所谓的均线粘合就是5、10、20、30、60、90、120、250日中有两条或三条、四条、五条、六条移动平均成本接近相同,或相差不大。例如三线粘合,我们只需要比较出这三条线中的最大成本...


所谓的均线粘合就是5、10、20、30、60、90、120、250日中有两条或三条、四条、五条、六条移动平均成本接近相同,或相差不大。例如三线粘合,我们只需要比较出这三条线中的最大成本和最小成本,把最大成本值和最小成本值之间的差距定义为某一个窄幅波动范围就可以了。
参数名 最小 最大 缺省
M1 0.00 1000.00 5.00
M2 0.00 1000.00 10.00
M3 0.00 1000.00 20.00
M4 0.00 1000.00 60.00
M5 0.00 1000.00 120.00
M6 0.00 1000.00 250.00
A:MAX(MAX(MA(CLOSE,M1),MA(CLOSE,M2)),MA(CLOSE,M3)),LINETHICK0;
B:MIN(MIN(MA(CLOSE,M1),MA(CLOSE,M2)),MA(CLOSE,M3)),LINETHICK0;
三线粘合:IF(RANGE(100*(A-B)/B,0,5),100*(A-B)/B,DRAWNULL),LINETHICK0;
SA:MAX(MAX(MA(CLOSE,M1),MA(CLOSE,M2)),MAX(MA(CLOSE,M3),MA(CLOSE,M4))),LINETHICK0;
SB:MIN(MIN(MA(CLOSE,M1),MA(CLOSE,M2)),MIN(MA(CLOSE,M3),MA(CLOSE,M4))),LINETHICK0;
四线粘合:IF(RANGE(100*(SA-SB)/SB,0,10),100*(SA-SB)/SB,DRAWNULL),LINETHICK0;
WA:MAX((MAX(MA(CLOSE,M1),MA(CLOSE,M2)),MAX(MA(CLOSE,M3),MA(CLOSE,M4))),MA(CLOSE,M5)),LINETHICK0;
WB:MIN((MIN(MA(CLOSE,M1),MA(CLOSE,M2)),MIN(MA(CLOSE,M3),MA(CLOSE,M4))),MA(CLOSE,M5)),LINETHICK0;
五线粘合:IF(RANGE(100*(WA-WB)/WB,0,15),100*(WA-WB)/WB,DRAWNULL),LINETHICK0;
LA:MAX((MAX(MA(CLOSE,M1),MA(CLOSE,M2)),MAX(MA(CLOSE,M3),MA(CLOSE,M4))),MAX(MA(CLOSE,M5),MA(CLOSE,M6))),LINETHICK0;
LB:MIN((MIN(MA(CLOSE,M1),MA(CLOSE,M2)),MIN(MA(CLOSE,M3),MA(CLOSE,M4))),MIN(MA(CLOSE,M5),MA(CLOSE,M6))),LINETHICK0;
六线粘合:IF(RANGE(100*(LA-LB)/LB,0,20),100*(LA-LB)/LB,DRAWNULL),LINETHICK0;
公式注释:
输出A:收盘价的M1日简单移动平均和收盘价的M2日简单移动平均的较大值和收盘价的M3日简单移动平均的较大值,LINETHICK0
输出B:收盘价的M1日简单移动平均和收盘价的M2日简单移动平均的较小值和收盘价的M3日简单移动平均的较小值,LINETHICK0
输出三线粘合:如果100*(A-B)/B位于0和5之间,返回100*(A-B)/B,否则返回无效数,LINETHICK0
输出SA:收盘价的M1日简单移动平均和收盘价的M2日简单移动平均的较大值和收盘价的M3日简单移动平均和收盘价的M4日简单移动平均的较大值的较大值,LINETHICK0
输出SB:收盘价的M1日简单移动平均和收盘价的M2日简单移动平均的较小值和收盘价的M3日简单移动平均和收盘价的M4日简单移动平均的较小值的较小值,LINETHICK0
输出四线粘合:如果100*(SA-SB)/SB位于0和10之间,返回100*(SA-SB)/SB,否则返回无效数,LINETHICK0
输出WA:(收盘价的M1日简单移动平均和收盘价的M2日简单移动平均的较大值,收盘价的M3日简单移动平均和收盘价的M4日简单移动平均的较大值)和收盘价的M5日简单移动平均的较大值,LINETHICK0
输出WB:(收盘价的M1日简单移动平均和收盘价的M2日简单移动平均的较小值,收盘价的M3日简单移动平均和收盘价的M4日简单移动平均的较小值)和收盘价的M5日简单移动平均的较小值,LINETHICK0

发表评论
加载中...

相关文章